Once again…

Yup, once again I’m installing Windows.

There are some people who sometimes are tempted to go for shopping or have some fun at the club, but me… I like from time to time to change the operating system [wat?]. I get the impression then that my computer has been cleared from all of the errors and failures which I did with his previous incarnation.

Okay, seriously, I wanted to finally compile MLPACK under Windows. According to the keonkim's guidelines, it went like clockwork.

========== Build: 40 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

In case I forgot how it was doing:

    1. Configurate MLPACK in Visual Studio 2015 Community:
      • create new project: File > New > Project from Existing Code
      • install dependencies: Tools > NuGet Package Manager > Manage NuGet Packages for Solution > Browse
        • OpenBLAS.0.2.14.1
        • boost.1.61.0
        • boost_unit_test_framework-vc140.1.61.0
        • boost_program_options-vc140.1.61.0
        • boost_random-vc140.1.61.0
        • boost_serialization-vc140.1.61.0
        • boost_math_c99-vc11.0
    2. Build latest stable Armadillo
cmake -G "Visual Studio 14 2015 Win64"- BLAS_LIBRARY:FILEPATH="C:/projects/mlpack-2.0.3/packages/OpenBLAS.0.2.14.1/lib/native/lib/x64/libopenblas.dll.a" -DLAPACK_LIBRARY:FILEPATH="C:/projects/mlpack-2.0.3/packages/OpenBLAS.0.2.14.1/lib/native/lib/x64/libopenblas.dll.a" -DCMAKE_PREFIX:FILEPATH="C:/projects/armadillo" -DBUILD_SHARED_LIBS=OFF ..

 3. Build latest stable MLPACK

cmake -G "Visual Studio 14 2015 Win64" -DBLAS_LIBRARY:FILEPATH="C:/projects/mlpack-2.0.3/packages/OpenBLAS.0.2.14.1/lib/native/lib/x64/libopenblas.dll.a" -DLAPACK_LIBRARY:FILEPATH="C:/projects/mlpack-2.0.3/packages/OpenBLAS.0.2.14.1/lib/native/lib/x64/libopenblas.dll.a" -DARMADILLO_INCLUDE_DIR="C:/projects/armadillo-7.400.1/include" -DARMADILLO_LIBRARY:FILEPATH="C:/projects/armadillo-7.400.1/build/Debug/armadillo.lib" -DBOOST_INCLUDEDIR:PATH="C:/projects/mlpack-2.0.3/packages/boost.1.61.0.0/lib/native/include" -DBOOST_LIBRARYDIR:PATH="C:/projects/mlpack-2.0.3/packages/boost_libs" -DDEBUG=ON -DPROFILE=OFF ..
Advertisements

6 thoughts on “Once again…

  1. I followed all the steps properly and I get the following error
    CMake Error at C:/Program Files/CMake/share/cmake-3.7/Modules/FindBoost.cmake:1793 (message):
    Unable to find the requested Boost libraries.

    Boost version: 1.61.0

    Boost include path:
    C:/projects/mlpack-master/packages/boost.1.61.0.0/lib/native/include

    Could not find the following Boost libraries:

    boost_unit_test_framework
    boost_serialization

    Some (but not all) of the required Boost libraries were found. You may
    need to install these additional Boost libraries. Alternatively, set
    BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT
    to the location of Boost.
    Call Stack (most recent call first):
    CMakeLists.txt:270 (find_package)

    windows CMake version 3.7.1

    Liked by 1 person

  2. The program mentioned in this tutorial is working fine.
    But when I try to run the covariance code in
    http://www.mlpack.org/docs/mlpack-2.1.1/doxygen.php?doc=sample.html
    I get sixteen “linker 2019” errors.

    unresolved external symbol sdot_ referenced in function “double __cdecl arma::blas::dot(unsigned __int64,double const *,double const *)” (??$dot@N@blas@arma@@YAN_KPEBN1@Z LINE 1

    unresolved external symbol ddot_ referenced in function “double __cdecl arma::blas::dot(unsigned __int64,double const *,double const *)” (??$dot@N@blas@arma@@YAN_KPEBN1@Z LINE 1

    and many more

    Iam new to visual studio and mlpack. Please help!

    Liked by 1 person

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s